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Frame Analysis Using Multiframe

1. The software is on the computers in the College of Architecture in Programs under the Windows
Start menu (see https://wikis.arch.tamu.edu/display/HELPDESK/Computer+Accounts for lab

locations). Multiframe is under the Bentley Engineering menu.

2. There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks

and order in greater detail. The first task is to define the unit system:

e Choose Units... from the View menu. Unit sets are available, but specific units can also
be selected by double clicking on a unit or format and making a selection from the menu.

Units
nit Set: Canfiguration:
Americgn Unit Type Unit Decimal Places| Format A
’;L_‘?“ﬁ'"a” 1 |Length it - ] Ficed Decimal | |
ritis Em : :
Canadian 2_ Angle _ d.eg 3 F?xed Dec?mal
European 3_ Deflection in 3 Fixed Decimal
Japanese 4_Rcrtatinn dey 3 Fixed Decimal
S_Fcurc:e kip 3 Fixed Decimal
B_ hdoment lkaf -1t 3 Fixed Decimal
T-'_ Dist. Force lkafoft 3 Fixed Decimal
8_ Stress ksi 3 Fixed Decimal
E__MESS Ik 3 Fixed Decima
1E_Massienmh Ikt 3 Fixed Decimsl
l.ﬂ.rea in? 3 Fixed Decimal
i it of Inetia in"4 3 Fixed Decimal
EDensﬂ\; lhfit= 3 Fized Decimal
i Section Modulus in® 3 Fixed Decimal [t |
Ok | Cancel |
3. To see the scale of the geometry, a grid option is available: x|
e Choose Grid... from the View menu Speei i T
% [1.000 ft nap
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[ |1.EIIZID It

4. To create the geometry, you must be in the Frame window
(default). The symbol is the frame in the window toolbar:

The Member toolbar shows ways to create members:

Cancel |
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The Generate toolbar has convenient tools to create typical structural shapes.
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e To create a frame, use the multi-bay frame button: “
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e Enter the number of bays (horizontally), number of stories (vertically) and the

corresponding spacings:
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x4

— Prirnary Structure
Mumber of bays
Mumber of stories |1—
Humber of frames |1—
Bay spacing [20000 &
Story height [so00 & s
Frame spacing IW uimits: /77””

— Secondany Stucture LTy
Wumber of Secondary Beams ID—
Wumber of Tertian Beams ID—
Secondany Beam Directicn Iﬁ

’TI Cancel |
e |f the frame does not have regular bays, use the add connected P’
members button to create segments: JJ LN A

e Select a starting point and ending point with the cursor. The location of the cursor and
the segment length is displayed at the bottom of the geometry window. The ESC button

will end the segmented drawing.

e The geometry can be set precisely by selecting the joint (drag), and bringing up the joint
properties menu (right click) to set the coordinates.

e The support types can be set by selecting
the joint (drag) and using the Joint Toolbar
(fixed shown), or the Frame / Joint
Restraint ... menu (right click).

NOTE: If the support appears at both ends
of the member, you had the member

selected rather than the joint. Select the joint to change

......

support for and right click to select the joint restraints
menu or select the correct support on the joint toolbar.

The support forces will be determined in the analysis.

Xl
Restraints
oA = e
LAk o £ a5
Restrained displacements:
¢y B2
r ¥ Cancel |
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5. All members must have sections assigned (see section 6.) in order to calculate reactions and

deflections. To use a standard steel section proceed to step 6. For custom sections the
section information must be entered. To define a section:

-

e Choose Edit Sections / Add

Section... from the Edit —
menu Name: | Mew Seckion Properties:
e Type a name for your new Group:  |Customl =] Property | Value | units | [a]
section Custom1 1| Weight 0.000 .Ibm
Custom? 2 | A 0o0n. int2
e Choose group Frame from Custams3 I 0.000, ..in%
the group names provided RS ..., s S L
group S Proy 5| 0000 it
so that the section will D 5| E 0000 ksi
remain with the file data i 0000 ksi
8_ o] 0.00a in
e Choose a shape. The Flat B 3 | B 0o0o i
Bar shape is a rectangular LR S a.000, ...
. 11 T 0.000 in
section. Shape: |F|at Bar ﬂ 42 | fy 0.000 s |
e Enter the cross section data. ok | cancel |
Table values 1-9 must have values for a Flat Bar, but not all are used for every analysis. A
recommendation is to put the value of 1 for those properties you don’t know or care about.
Properties like tz, tw, etc. refer to wide flange sections.
e Answer any query. If the message says there is an error, the section will not be created
until the error is corrected.

6. The standard sections library loaded is for the United States. If another section library is
needed, use the Open Sections Library... command under the file menu, choose the library
folder, and select the SectionsLibrary.slb file.

Select the members (drag to make bold) and assign sections with the Section button on the
Member toolbar:
|7 &6 1] A1
e Choose the group name and section name:
(STANDARD SHAPES) (CUSTOM)
Select Section x|
Group: Section: B SR
HP ;I generic ]
W ~ Wwiddn335 ~
M ] |wae2a0 = ggﬂllfle.&ngle
5 Widd265 Fine
WT Widd262 Sq Tubs
MT Widdu248 Fect Tube
5T Widd230 Hes Fond
i N I HSS Square
HF ' |wanesss Hs® Rectangular
5 e g
gipe.l. i a ﬁg*igg Custamn3
Roct Tube v |ueonass 2] Cancel [ Coned |
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If there is an area that has a uniformly distributed load, load panels may be defined in the

Frame window. Because the loaded area may not be visible in the current view, choose the
View button at the lower left of the Frame window. The options for view are shown. (See
3D Frames, last page.)

The frame geometry is complete, and in order to define the load ——
conditions you must be in the Load window represented by the || = B! @ 5 | |

Choose the panel type (rectangular, 4-node, or 3-node) from the ey

menu and select the corners. If the area is rectangular, only the

opposite corners need to be selected.

Select the panel and from the pop-up menu, or the

Frame menu, specify the load panel supports. The
default supports are on all sides. If the panel is one

way, chose the corresponding picture

green arrow:

Load Panel Support Types

4-node Panel Side Supports:

= B [

The Load toolbar allows a joint to be loaded with a force or a moment in global coordinates,
shown by the first two buttons after the display numbers button. It allows a member to be
loaded with a distributed load, concentrated load or moment (next three buttons) in global
coordinates, as well as loading with distributed or single force or moment in the local
coordinate system (next three buttons). It allows a load panel to be loaded with a distributed
load in global or local coordinates (last two buttons).

Choose the member to be loaded (drag) and select
the load type (here shown for global distributed

loading):

Choose the distribution type and
direction. Note that the arrow shown
is the direction of the loading. There
is no need to put in negative values
for downward loading.

Enter the values of the load and
distances (if any). Distances can be
entered as a function of the length ,
i.e. L/2, L/4...

Area load units may have to be
changed in the View Units dialogue.

NOTE: Do not put support reactions as
applied loads. The analysis will
determine the reaction values.

1.0
+

SR L AR T

Global Distributed Load
— Shape
W, e
b
s 5 Left Magritude 1.000 kip/ft

Right Magrituds |1 000 kip/ft
Left Distance ID.DDD fi
Right Distarcs |D.EIIZIEI ft

(1] 4 I Cancel |
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10.

11.

12.

Multiframe4D will automatically generate a grouping

called a Load Case named Load Case 1 when a load is
created. All additional loads will be added to this load
case unless a new load case is defined (Add case under the
Case menu).

In order to run the analysis after the geometry, member

F2013abn

Sections
mal

Load Case 1
Ready

Zi\arche

properties and loading has been defined:

Choose Linear from the Analyze menu

If the analysis is successful, you can view the results in the
Plot window represented by the red moment diagram:

The Plot toolbar allows the numerical values to be shown (1.0
button), the reaction arrows to be shown (brown up arrow) and
reaction moments to be shown (brown curved arrow):

To show the moment diagram, Choose the red Moment button ” e

To show the shear diagram, Choose the green Shear button

To show the axial force diagram, Choose the purple Axial
Force button

To show the deflection diagram, Choose the blue Deflection

button

To animate the deflection diagram,

——
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Choose Animate... from the Display a2

menu. You can also save the animation to Mz )
a .avi file by checking the box. :

To see exact values of shear, moment and 3

deflection, double click on the member

and move the vertical cross hair with the 3

mouse. The ESC key will return you to

the window.
Mz' 194585134 Ibf-ft
W' 0.000 bt
oy -0.0780In
iy =500 .000 kit
Dizt 12,5001

E _

3

Ihlax Mz’ 18577370 boi-ft
Mz Wy 52:30.000 bt
e oy’ 0.075in
R 500,000 [bfit
Dist 12,500 f

Ready

Static Cazer Load Case 1 Member 3 (¥ Primary Beam) all

Z:harche
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13. The Data window (D) allows you to view all data “entered”
for the geometry, sections and loading. These values can be H [l D1

edited.

14. The Results window (R) allows you to view all results of the
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| &/ M| E] E]

IFERESEDE

analysis including displacements, reactions, member forces (actions) and stresses. These
values can be cut and pasted into other Windows programs such as Word or Excel.

NOTE: Px’ refers to the axial load (P)
in the local axis x direction (x’). Vy’
refers to the shear perpendicular to
the local x axis, and Mz’ refers to the
bending moment.

15. To save the file Choose Save from the

16. To load an existing file Choose Open..

Static Case: Load Case 1 -
. Px' vy Mz
Memb| Label | Joint ‘ Ibf | Ibf ‘ T |
1 1 Calumn 1 6250000 17865320 -9725.754
2 1 Column 3 -B2E0000 0 1786320 19577 371
3 2 Calumn 2 G250.000° 1786320 9725754
4 2 Calumn 4 -G250.000 ¢ -17586.320 19577.571
5 3 ¥ Prima 3 1786.320 0 B250.000° 19577.371
5] 3 * Prima 4 -1¥E6.32000 5250000 19577 .37 I
-
IEL\Memher Actions A Max Acti] 4 [
Ready Z:\arche
File menu.

. from the File menu. .

17. To print a plot Choose Print Window... from the File menu. As an alternative, you may copy

the plot (Ctrl+c) and paste it in a word

Example of Combined Stresses:

processing document (Ctrl+v).

for member 3: Mmax = 19.6 k-ft, P= 1.76 k
knowing A = 21.46 in?, | = 796.0 in*, ¢ = 7.08 in

_ 176k +19.6k‘“~7.08in.12in
™ 21.46in° 796in* ft

Results window:

= 0.082ksi+ 2.092ksi = 2.174Kksi

Ready

Static Case: Load Case 1 -
. 5hz" top Shz" hot S Su°+5bz" top | SK'+5hz’ hot
Memb| Label | Joint | ksi ! ksi | kws.i ‘ ksi ksi ! ksi
1 1 Column: 1 1.039 -1.039: -1152.481 0.286 1.325 -0.753
2 1 Column: 3 -2.092 2092 1152461 0.286 -1.806 2378
3 2 Column: 2 -1.039 1039 1152461 0.256 0753 1.325
4 2 Column 4 2.092 -2092: 1152481 0.2386 2375 -1.808
5 3 MWPrima: 3 -2.092 2092 4032245 0.052 =201 2174
G 3 WPrima: 4 -2.092 2092 -4032.245 0.052 -2.011 2174
|
|4 [ » [\Member Stresses A Max Stresses £ Mernber [ « i

Z:\arche31\FOst assignsimultiframelSa. mfd®*  |MUM

where Sx’ refers to the axial stress, Sy’ refers to the bending stress around the local vertical
axis and Sz’ refers to the bending stress around the local horizontal axis.
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For 3D Frames:

e There is a tutorial in the Help menu (Chapter 1 — 3D Tutorial) that lists the tasks and order in
greater detail. It expects that you have been through the 2D tutorial to build on the steps

already mastered.
« There are standard 3D frame shapes on the frame toolbar. ‘ O R A HDs

i rfh

e It is very useful to change the view to isometric with the View Button

* Frame [Z]@
T S T == = v R e I

S NAlElLZE ] 8 E

Sections E .

/ View
P

Top
ik 1
- Left Front

BERRF IR RN

View | -ito

L.‘xg.'.i
Bottom

« If you wish to have additional beams supported by the beams of your frame, choose the beam
and use the Subdivide Member menu under Geometry. This will make additional joints, but
keep the segments together.

F ~
Subdivide Member =5
Mo. of subdivisions ]
Member| Proportion Length 7
1 1 0.500 10.000 E
2 0.500 10.000
3| Total 1.000 20.000 oK
Cancel
-
.
¥ 2
Connect to existing Group as Design Member u u

4
u

« In order to model a beam end as simply supported, you must release the restraint preventing
rotation about the x-x axis of the beam. The pinned ends menu is useful for segments or

subdivided members. .

[/ vl ERIP2 A
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Or, by selecting a segment and right clicking for a
menu, you can use Member Releases (also under the
Frame menu) to release the Major Bending (M'z) for

one end or both.

F2013abn
r |
Member Releases &J
Member Releases
0K
/ s
Joint 1 Joint 2:
Oty Torsion Orv
[my' Minor Bending [ my
Mz Major Bending [ iz
ey Axial [Ty

« It is necessary to understand the local member axes to assign the correct load direction.
Choosing the local loading types will show the member orientation with respect to the load

direction.
® Load =<
TN A AT (A ™
Local Distributed Load
51000 Shape
1000100 W W W,
000~ 4, :
tigp | | 2,
1000 A 000 *y e
1000 u
0o Direction
~ Left Magnitude 1.0000 IBf/E
N\ e . Right Magnitude 1.000 Ibfift
Load Casze 1 p
T T T T T T 2 Left Digtance
View | .m I o T 8 0.000
E . .
~ AT T (s Right Distance 0.000
ok | Cancel |




