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Frame Analysis Using Multiframe

1. The software is on the computers in the College of Architecture in Programs under the Windows
Start menu (see https://wikis.arch.tamu.edu/display/HELPDESK/Computer+Accounts for lab
locations). Multiframe is under the Bentley Engineering menu.

2. There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks
and order in greater detail. The first task is to define the unit system:

e Choose Units... from the View menu. Unit sets are available, but specific units can
also be selected by double clicking on a unit or format and making a selection from the

menu.
Units
nit Set: Canfiguration:
American Unit Type Unit Decimal Places| Format ~
gk‘?‘f;"ﬂ“ 1 |Length ft - 3 Fixed Decimal | |
il = : :
Canadian 2_ Angle _ d.eg 3 F?xed Dec?mal
European 3_ Deflection in 3 Fixed Decimal
Japanese 4_Rcdation dey 3 Fixed Decimal
S_Fcurc:e [l 3 Fixed Decimal
B_ hdarment lkaf -1t 3 Fixed Decimal
T-'_ Dist. Force lkafoft 3 Fixed Decimal
8_ Stress ksi 3 Fixed Decimal
9 |Mass b 3 Fixed Decimal
EMagsn_ength Ikt 3 Fixed Decimal
l.ﬂ.rea in? 3 Fixed Decimal
i it of Inertia in“4 3 Fixed Decimal
EDensﬂ\; Ikt 3 Fixed Decimal
i Section Modulus in® 3 Fixed Decimal 4|
] | Cancel |
3. To see the scale of the geometry, a grid option is available: eid x|
e Choose Grid... from the View menu SpEE Display "~
x [1.000 f V Snap
¥ Wisible
[ |1.DDD It
Cancel |

4. To create the geometry, you must be in the Frame window

(default). The symbol is the
frame in the window toolbar: JJ 13 ® | |

The Member toolbar shows ways to create members:

P 2 [ A e

The Generate toolbar has convenient tools to create typical structural shapes.

e S == - = [ e

e To create a frame, use the multi-bay frame button:
=~ [m

1



https://wikis.arch.tamu.edu/display/HELPDESK/Computer+Accounts
http://www.formsys.com/mflearning
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e Enter the number of bays (horizontally), number of stories (vertically) and the
corresponding spacings:

x

— Primary Structure

Mumber of bays

Mumber of stories |1—

Humber of frames |1—

Biay spacing IW ft

Stary height IW ft o

Frame spacing IW units /77””
— Secondany Stucture LTy

Wumber of Secondary Beams ID—

Wumber of Tertian Beams ID—

Secondany Beam Directicn Iﬁ

’TI Cancel |

e |f the frame does not have regular bays, use the add connected
members button to create segments: JJ A NA

e Select a starting point and ending point with the cursor. The location of the cursor and
the segment length is displayed at the bottom of the geometry window. The ESC button
will end the segmented drawing.

e The geometry can be set precisely by selecting the joint (drag), and bringing up the joint
properties menu (right click) to set the coordinates.

e The support types can be set by selecting = _ =
the joint (drag) and using the Joint Toolbar | ™ Flestraints
(fixed shown), or the Frame / Joint A A m |a
Restraint ... menu (right click).
: @ & #® 3
NOTE: If the support appears at both ends 4~ - _
of the member, you had the member restenes dipeeenens
selected rather than the joint. Select the joint to change ,’*_ *”,7 ,'3_2 Cancel |

support for and right click to select the joint restraints

menu or select the correct support on the joint toolbar.

The support forces will be determined in the analysis.
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5. All members must have sections assigned (see section 6.) in order to calculate reactions and
deflections. To use a standard steel section proceed to step 6. For custom sections the
section information must be entered. To define a section:

e Choose Edit Sections / Add

Mew Section

-,

Section... from the Edit
menu Marme: | Mew Seckion Properties:
G . Customl - Property | Value Units | ~
. Typ_e a name for your new Siolp |Cjztzrr:1 - T et o0 b fad
section CLtom? 2 | 2, 0000 iRt
Cuskom3 3 [ Q.000 in™d4
L] Choose gI’OUp Fl’ame from Frarme E |-5,. 0.000 in"4
the group names provided 5| 0000 in"d
so that the section will D L 0000 ...k
. - . . =i
remain with the file data G i -
L#)l El_ B Q.000 in
e Choose a s_hape. The Flat =1 v
Bar shape is a rectangular ] tw gooe. i
section. Shape: |Flat Ear ﬂ 12 | fy 0000 ksi kd
e Enter the cross section ok | _cancel
data.
Table values 1-9 must have values for a Flat Bar, but not all are used for every analysis. A
recommendation is to put the value of 1 for those properties you don’t know or care about.
Properties like ty, t,, etc. refer to wide flange sections.
e Answer any query. If the message says there is an error, the section will not be created
until the error is corrected.

6. The standard sections library loaded is for the United States. If another section library is
needed, use the Open Sections Library... command under the file menu, choose the library
folder, and select the SectionsLibrary.slb file.

Select the members (drag to make bold) and assign sections with the Section button on the
Member toolbar:
IPaErdl ATl
e Choose the group name and section name:
(STANDARD SHAPES) (CUSTOM)
Select Section %]

Group: Section: B Szl

' 1~ widdw335 | :Egle

gl w:z:ggg . Double Angle

WT Widdx262 E'c'iembe

il Wik Rect Tube

C T I 25 S

HP WADYBES 152 Rectangular

Bt o i

Poe WADH503 Custom
59 Tub wid0x480 ancel |
quc#uebe bl wanidas el Cancel Cancel
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If there is an area that has a uniformly distributed load, load panels may be defined in the

Frame window. Because the loaded area may not be visible in the current view, choose the
View button at the lower left of the Frame window. The options for view are shown. (See
3D Frames, last page.)

The frame geometry is complete, and in order to define the load

Choose the panel type (rectangular, 4-node, or 3-node) from the ey

menu and select the corners. If the area is rectangular, only the

opposite corners need to be selected.

Select the panel and from the pop-up menu, or the
Frame menu, specify the load panel supports. The
default supports are on all sides. If the panel is one

way, chose the corresponding picture

Load Panel Support Types

4-node Panel Side Supports:

= B [

—
conditions you must be in the Load window represented by the JJ Pl EL] | |
green arrow:

The Load toolbar allows a joint to be loaded with a force or a moment in global coordinates,
shown by the first two buttons after the display numbers button. It allows a member to be
loaded with a distributed load, concentrated load or moment (next three buttons) in global
coordinates, as well as loading with distributed or single force or moment in the local
coordinate system (next three buttons). It allows a load panel to be loaded with a distributed
load in global or local coordinates (last two buttons).

Choose the member to be loaded (drag) and select the
load type (here shown for global distributed loading):

Choose the distribution type and
direction. Note that the arrow shown
is the direction of the loading. There
is no need to put in negative values
for downward loading.

Enter the values of the load and
distances (if any). Distances can be
entered as a function of the length ,
i.e. L/2, L/4...

Area load units may have to be
changed in the View Units dialogue.

NOTE: Do not put support reactions as
applied loads. The analysis will
determine the reaction values.

Pld O r vyt wy

RN L R T A
Global Distributed Load ﬂ
—Shape
M| B || o
HY: ‘T“H A HE’ 1TRH
— Direction
5 5 Left Magritude 7,000 kipt

Ly

Right Magnitude |1 .0oo kipft
Left Distance |n.unu ft
Right Distance |n.unu ft

Ok I Cancel |
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11.

12.

Multiframe will automatically generate a grouping calleda |/
Load Case named Load Case 1 when a load is created. All
additional loads will be added to this load case unless a

new load case is defined (Add case under the Case menu).

In order to run the analysis after the geometry, member
properties and loading has been defined:
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Sections
mal

Load Case 1
Ready

Zi\arche

Choose Linear from the Analyze menu

If the analysis is successful, you can view the results in the ]
Plot window represented by the red moment diagram: || =lle ‘
The Plot toolbar allows the numerical values to be shown (1.0 L —
button), the reaction arrows to be shown (brown up arrow) and “|:| ks B S o
reaction moments to be shown (brown curved arrow):
e To show the moment diagram, Choose the red Moment button ” [t B S+
e To show the shear diagram, Choose the green Shear button JJ]EW; LA |
e To show the axial force diagram, Choose the purple Axial Force

button = & &+ e
. 'tlj'ottshow the deflection diagram, Choose the blue Deflection J”EHE S f 8 ([ o

utton

To animate the deflection diagram, Choose
Animate... from the Display menu. You can >

also save the animation to a .avi file by
checking the box.

4

To see exact values of shear, moment and 3
deflection, double click on the member and o
move the vertical cross hair with the mouse. 3
The ESC key will return you to the window.
™
Wiz' 19455134 bf-1t 3
Wy 0,000 [kbf
dy' 0078 in
iyt =500 .000 kit

Digt 12.500 1

-

2 e Wz’
Mlas Wy
e oy
[T
Dist

19577 370 bi-1t
6230000 bt
0.07&in
S00.000 bttt
12.5001

Ready

Static Cazer Load Case 1 Member 3 (X Primary Beam) all

Z:harche
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13. The Data window (D) allows you to view all data “entered”
for the geometry, sections and loading. These values can be

edited.
14.
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Windows programs such as Word or Excel.

NOTE: Px’ refers to the axial load (P)
in the local axis x direction (x’). Vy’
refers to the shear perpendicular to the
local x axis, and Mz’ refers to the

S2013abn

[[alclalci=llala]

The Results window (R) allows you to view all results of the analysis including
displacements, reactions, member forces (actions) and
stresses. These values can be cut and pasted into other

bending moment.

15.
File menu.

16.
from the File menu.

17.

To save the file Choose Save from the

To load an existing file Choose Open...

[micialcicllala]
Static Case: Load Case 1 -
_ Px' Wy Mz’
Memb| Label [ Joint | Ibf ‘ Ibf | IbE-ft ‘
1 1 Column: 1 5230000 -1736.320 ¢ -9725.784
2 1 WColumni 3 6250000 1786320 -19577.371
3 2 Column: 2 5230000 1736320 9725784
4 2 Column: 4 -6250.000 ¢ -1786 320 : 19577371
3 3 M Prima: 3 1786.320 0 6230.000: 19377 .31
G 3 M Prima: 4 -1786.320 0 6250000 18577 371 -
-
IE[;\Memher Actions £ Max Acti] < | r |_
Ready Zilarche

the plot (Ctrl+c) and paste it in a word processing document (Ctrl+v).

Example of Combined Stresses:

for member 3: My = 19.6 k-ft, P= 1.76 k
knowing A = 21.46 in?, 1 =796.0 in* ¢ = 7.08 in

1.76k N 19.6“"™.7.08in 12in

= 0.082ksi + 2.092ksi = 2.174Kksi

max =2 - 4
21.46in 796in ft
Results window:
Static Case: Load Case 1 -
Memb| Labet | Joint Shz 1_0|J Shz I_mt W Sx_ Sx +Shz_ top | Sx +Shz_ hot
ksi ksi ksi ksi ksi ksi
1 1 Column 1 1.033 -1.039 0 -1152.461 0.2586 1.325 -0.753
2 1 Column 3 -2.092 2092 1152 461 0.286 -1.806 2378
3 2 Column 2 -1.033 1039 1152461 0.2586 -0.753 1.325
4 2 Column b 2.092 -2.092 0 11524681 0.286 2378 -1.808
5 3 H Prima 3 -2.092 2092 4032245 0.052 =201 2174
G 3 ¥ Prima 4 -2.092 2092 4032245 0.052 -2.011 2174
|
|4 [ [\Member Stresses A Max Stresses £ Mernber [ « i
Ready Z:\arche31\Fosh assignsimultiframelSa. mfd*  |MUM

where Sx’ refers to the axial stress, Sy’ refers to the bending stress around the local vertical axis

and Sz’ refers to the bending stress around the local horizontal axis.

To print a plot Choose Print Window... from the File menu. As an alternative, you may copy
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For 3D Frames:

« There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks
and order in greater detail. It expects that you have been through the 2D tutorial to build on

the steps already mastered.

« There are standard 3D frame shapes on the frame toolbar. ‘ = O RS Em e

« It is very useful to change the view to isometric with the View Button

* Frame [Z]@
T S T == = v R e I

S NAlElLZE ] 8 E

Sections E .

/ View
P

Top
ik -
Left Front

B

BERRF IR RN

View | -ito

L.‘xg.'.i
Bottom

« If you wish to have additional beams supported by the beams of your frame, choose the beam
and use the Subdivide Member menu under Geometry. This will make additional joints, but

keep the segments together.

r ~
Subdivide Member S5
No. of subdivisions ]
Member| Proportion Length 7
1 1 0.500 10.000 E
2 z 0.500 10.000
3 | Total 1.000 20.000 0K
]
.
H 2
Connect to existing Group as Design Member u

4

«In order to model a beam end as simply supported, you must release the restraint preventing
rotation about the x-x axis of the beam. The pinned ends menu is useful for segments or

subdivided members. :
Il ER PP

7
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Or, by selecting a segment and right clicking for a
menu, you can use Member Releases (also under the
Frame menu) to release the Major Bending (M'z) for

one end or both.

S2013abn
r h |
Member Releases &J
Member Releases
/ s
Joint 1: Joint 2:
Ity Torsion O
[y Minor Bending My
Mz Major Bending 0 Mz'
e Axial ey

o It is necessary to understand the local member axes to assign the correct load direction.

Choosing the local loading types will show the member orientation with respect to the load

direction.
®iLoad =1
T T A I A
Local Distributed Load
51000 Shape
1000100 W W W,
1000 - :
4 | | A,
1000 A 000 *y e
000 u
0o Direction
-~ i Left Magnitude 1.0000 (=13
.@ e b Right Magnitude 1.000 Ibr At
Load Case 1 2
— — — . — T 2 Left Distance
View | .m I o T 8 0.000
H . .
~ AT T (s Right Distance 0.000
- ] | Cancel |




