ARCH 331

Note Set 12.3

Frame Analysis Using Multiframe

S2013abn

1. The software is on the computers in the College of Architecture in Programs under the Windows
Start menu (see https://wikis.arch.tamu.edu/display/HELPDESK/Computer+Accounts for lab

locations). Multiframe is under the Bentley Engineering menu.

2. There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks
and order in greater detail. The first task is to define the unit system:

e Choose Units... from the View menu. Unit sets are available, but specific units can
also be selected by double clicking on a unit or format and making a selection from the
menu. Pressure units are used for distributed area loads on load panels.

Units
nit Set: Canfiguration:
American Unit Type Unit Decimal Places| Format ~
gk‘?‘f;"ﬂ“ 1 |Length ft 3 Fixed Decimal | |
il = : :
Canadian 2_ Angle _ d.eg 3 F?xed Dec?mal
European 3_ Deflection in 3 Fixed Decimal
Japanese 4_Rcdation dey 3 Fixed Decimal
S_Fcurc:e kip 3 Fixed Decimal
B_ hdarment lkaf -1t 3 Fixed Decimal
T-'_ Dist. Force lkafoft 3 Fixed Decimal
8_ Stress ksi 3 Fixed Decimal
9 |Mass b 3 Fixed Decimal
EMagsn_ength kit 3 Fixed Decimal
11 [Area in? 3 Fixed Decimal
i it of Inertia in“4 3 Fixed Decimal
13 |Density kit 3 Fixed Decimal
14 [Section Modulus in® 3 Fixed Decimal 4|
lTl Cancel |
3. To see the scale of the geometry, a grid option is available: erid x|
e Choose Grid... from the View menu Spe el Display
« [1.000 f W Snap
v Wisible
1 |1.EIEID It
& ]
Cancel |

4. To create the geometry, you must be in the Frame window (default). The symbol is the
frame in the window toolbar:

The Member toolbar shows
ways to create members:

The Generate toolbar has convenient tools to create typical structural

shapes.

e To create a frame, use the multi-bay frame button:
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Enter the number of bays (horizontally), number of stories (vertically) and the
corresponding spacings:

Generate Frame il

— Primary Structure

Mumber of baps
Mumber of stories |1—
Humber of frames |1—

Bay spacing IW ft
Stary height W ft
Frame spacing IW umits

= Secandany Stucture

MHumber of Secondan Beams ID

Wumber of Tiertian Eeams ID

Secandan Beam Direstion I ,,I
ak. I Cahicel |

e If the frame does not have regular bays, use the add connected
members button to create segments: JJ o

C N A

e Select a starting point and ending point with the cursor. The location of the cursor and
the segment length is displayed at the bottom of the geometry window. The ESC button
will end the segmented drawing.

e The geometry can be set precisely by selecting the joint (drag), and bringing up the joint
properties menu (right click) to set the coordinates.

e The support types can be set by selecting =T X
the joint (drag) and using the Joint Toolbar | == Restraints
(fixed shown), or the Frame / Joint =1 ||
Restraint ... menu (right click). S
NOTE: If the support appears at both ends 4 ®os %
of the member, you had the member 4

selected rather than the joint. Select the Restrained displacements:
joint to change support for and right click to select the ¥y Bz —
joint restraints menu or select the correct support on the u o m _Concel |

joint toolbar.

The support forces will be determined in the analysis.
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5. All members must have sections assigned (see section 6.) in order to calculate reactions and
deflections. To use a standard steel section proceed to step 6. For custom sections the
section information must be entered. To define a section:

Choose Edit Sections / Add

4

-,

Section... from the Edit | Mew Section
menu Name: | Mew Sechion Properties:
e Type a name for your new Goup:  [customt | Property | Value | Units | [
section T 1| Weight 0000 kit
Cushom? 2 A, 0000 int2
e Choose group Frame from Custom3 E 0000 intd
the group names provided Frame 1 | 0000 in"d
so that the section will I 0.000;,..n4
in with the file data 0 L - i S
remain wi T-'_ G 0.000 ksi
e Choose a shape. The Flat g | D 0000 - n
Bar shape is a rectangular [ E— LT L0 el
A p g £ tf 0.000 in
section. 11 tuy 0.000 in
. Shape: Flat & - 17 | i
e Enter the cross section pei | Pl B =zl 000 ksl S
data. Ok, | Cancel |
Table values 1-9 must have values for a Flat Bar, but not all are used for every analysis. A
recommendation is to put the value of 1 for those properties you don’t know or care about.
Properties like ty, ty, etc. refer to wide flange sections.
e Answer any query. If the message says there is an error, the section will not be created
until the error is corrected.

6. The standard sections library loaded is for the United States. If another section library is
needed, use the Open Sections Library... command under the file menu, choose the library
folder, and select the SectionsLibrary.slb file.

Select the members (drag to make bold) and assign sections with the Section button on the
Member toolbar:
IPaE vl E IR ars
e Choose the group name and section name:
(STANDARD SHAPES) (CUSTOM)
Select Section X

Group: Section: B SR

W ~ Widdw33h ~ Eﬁgle ;I

M ] w230 = Double Angle

i e

MT Wddi243 20 Tube

5T Widd230 HEE Foond

i [ ]

* HS5 Rectangular

HP /404655 Curstom

Dovte Angl W Custon2

e e

Foct Tube v |usonass 2] Cancel [ Coned |
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7.

If there is an area that has a uniformly distributed load, load panels may be defined in the
Frame window. Because the loaded area may not be visible in the current view, choose the
View button at the lower left of the Frame window. The options for view are shown. (See
3D Frames, last page.)

e Choose the panel type (rectangular, 4-node, or 3-node) from the ey =
menu and select the corners. If the area is rectangular, only the
opposite corners need to be selected.

e Select the panel and from the pop-up menu, or the
Frame menu, specify the load panel supports. The _
default supports are on all sides. If the panel is one "““@Pm 5 SE‘E’ E

way, chose the corresponding picture

Load Panel Support Types

The frame geometry is complete, and in order to define the load ——
conditions you must be in the Load window represented by the JJ 5 T (@ | |
green arrow:

The Load toolbar allows a joint to be loaded with a force or a moment in global coordinates,
shown by the first two buttons after the display numbers button. It allows a member to be
loaded with a distributed load, concentrated load or moment (next three buttons) in global
coordinates, as well as loading with distributed or single force or moment in the local
coordinate system (next three buttons). It allows a load panel to be loaded with a distributed

load in global or local coordinates (last two buttons).
RN LT SRR . T2

e Choose the member to be loaded (drag) and select
the load type (here shown for global distributed LR LR LR A
loading):

e Choose the distribution type and X
direction. Note that the arrow
shown is the direction of the  Shape
loading. There is no need to put in WTITNE i“h U
negative values for downward T Aﬂﬂ-- dhatidarly
loading. R P

e Enter the values of the load and ~ Direction
distances (if any). Distances can be i < Left Magritude 1000 kip/ft
ﬁgfe[(/eg’ alf/:f.unctlon of the length , i i Right Magritude [fooo kit

k3 = Left Distance ID_DDD ft

e Area load units may have to be . T

changed in the View Units dialogue. SR '
OF. I Cancel |

NOTE: Do not put support reactions as

applied loads. The analysis will
determine the reaction values.
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Multiframe will automatically generate a grouping calleda |/,

Load Case named Load Case 1 when a load is created. All
additional loads will be added to this load case unless a 2
new load case is defined (Add case under the Case menu). l l l l l l

Load Case 1
Ready Zi\arche

10. In order to run the analysis after the geometry, member

properties and loading has been defined:
e Choose Linear from the Analyze menu

11. If the analysis is successful, you can view the results in the
Plot window represented by the red moment diagram: || = =l ‘
12. The Plot toolbar allows the numerical values to be shown (1.0 o
button), the reaction arrows to be shown (brown up arrow) and Hl:l S B L[4 D

reaction moments to be shown (brown curved arrow):

e To show the moment diagram, Choose the red Moment button ” [l 2 & [+

e To show the shear diagram, Choose the green Shear button J”TH__ v el o7 o
By |8 B o =
e To show the axial force diagram, Choose the purple Axial s
Force button [ & &[T o

e To show the deflection diagram, Choose the blue Deflection |
button [ s s & [} o

e To animate the deflection diagram, Choose Animate... from
the Display menu. You can also save the

animation to a .avi file by checking the My 2 P 6
box. e

e To plot the bending moment on the “top” 3;4‘4
choose Preferences from the Edit menu vy §
and under the Presentation tab Draw ’ §\\\kj
moments on the compression face dy ;

e To see exact values of shear, moment and
deflection, double click on the member
and move the vertical cross hair with the

E

mouse. The ESC key will return you to Mz 13485134Mif 2 e Mz’ 19577 370 bttt
- Wy 0.000 lbf Iz Wy 5250.000 lbf
the window. dy’ 0.078in M oy’ 0.078in
iyt -500.000 Ik frt Ifi: Wiyt S00.000 lkbf it
Dist 12.500 Dist 12.500 ft
Static Caze: Load Case 1 Member 3 (4 Primary Beam) all
Ready Z:harche
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13. The Data window (D) allows you to view all data “entered”
for the geometry, sections and loading. These values can be

edited.

14. The Results window (R) allows you to view all results of the
analysis including displacements, reactions, member forces (actions)
and stresses. These values can be cut and pasted into other Windows programs such as Word

or Excel.

NOTE: Px’ refers to the axial load (P)
in the local axis x direction (x’). Vy’
refers to the shear perpendicular to
the local x axis, and Mz’ refers to the

bending moment.

S2013abn

|

=1

] (D] [¥

| &/ M| E] E]

miaialcicliala

Static Case: Load Case 1

. Px’ vy Mz’

Memb| Label | Joint ‘ T | Ibf ‘ T |
1 1 Calumn 1 6250.000 ; -17586.5320 -9725.754
2 1 Column: 3 -6250.000 ¢ 1786320 -19577.371
3 2 Column 2 E250.000° 1786320 9725754
4 2 Column 4 -6250.000 1786320 19577.371
5 3 MPrima 3 1786.320 0 6250.000 19577371
B 3 MPrima 4 1786320 E250.000 -19577.371 |

-

MMemher Actions A Max Acti] 4 e
Ready Z:\arche

15. To save the file Choose Save from the File menu.

16. To load an existing file Choose Open... from the File menu.

17. To print a plot Choose Print Window... from the File menu. As an alternative, you may copy
the plot (Ctrl+c) and paste it in a word processing document (Ctrl+v).

Example of Combined Stresses:

for member 3: Mpnax = 19.6 k-ft, P= 1.76 k
knowing A = 21.46 in?, | = 796.0 in*, ¢ = 7.08 in

1.76k N 19.6“"".7.08in 12in

= 0.082ksi+ 2.092ksi = 2.174ksi

max 22 s 4
21.46in 796in ft
Results window:

Static Case: Load Case 1 -

Memb| Labet | Joint Shz t_op Shz I_Jot W Sn_ Sx +Shz_ top | Sx +Shz_ hot

ksi ksi ksi ksi ksi ksi

1 1 Column: 1 1.039 -1.039 ¢ 1152461 0.286 1.325 0753

2 1 Colurmn 3 -2.092 2092 1152461 0.286 -1.806 2378

3 2 Column: 2 -1.039 1039 1152461 0.286 -0.753 1.325

4 2 Column: 4 2.092 -2.092° 1152461 0.286 2378 -1.806

5 3 MPrima: 3 -2.092 2092 4032245 0.0s2 =201 2174

G 3 MPrima: 4 -2.092 2092 -4032.245 0.0&2 -2.01 2174
-

Ready

MMemher Stresses f Max Stresses A Member( +

[

Z:\arche31\Fosh assignsimultiframelSa. mfd*  |MUM

where Sx’ refers to the axial stress, Sy’ refers to the bending stress around the local vertical
axis and Sz’ refers to the bending stress around the local horizontal axis.
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« There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks
and order in greater detail. It expects that you have been through the 2D tutorial to build on

the steps already mastered.

e There are standard 3D frame shapes on the frame toolbar. ‘ S B == <z

e It is very useful to change the view to isometric with the View Button

e ¥}
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« If you wish to have additional beams supported by the beams of your frame, choose the beam
and use the Subdivide Member menu under Geometry. This will make additional joints, but
keep the segments together.

.
Subdivide Member

[S)

No. of subdivisions

Member

Proportion

Length

1

1

0.500

10.000

2

0.500

10.000

3

Total

1.000

20.000

Connect to existing

Group as Design Member

Cancel

4

« In order to model a beam end as simply supported, you must release the restraint preventing
rotation about the x-x axis of the beam. The pinned ends menu is useful for segments or
subdivided members.
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Or, by selecting a segment and right clicking for a
menu, you can use Member Releases (also under the
Frame menu) to release the Major Bending (M'z) for

one end or both.

S2013abn
r |
Member Releases &J
Member Releases
0K
/ s
Joint 1 Joint 2:
Oty Torsion Orv
[my' Minor Bending [ my
Mz Major Bending [ iz
ey Axial [Ty

« It is necessary to understand the local member axes to assign the correct load direction.
Choosing the local loading types will show the member orientation with respect to the load

direction.
® Load =<
TN A AT (A ™
Local Distributed Load
51000 Shape
1000100 W W W,
000~ 4, :
tigp | | 2,
1000 A 000 *y e
1000 u
0o Direction
~ Left Magnitude 1.0000 IBf/E
N\ e . Right Magnitude 1.000 Ibfift
Load Casze 1 p
T T T T T T 2 Left Digtance
View | .m I o T 8 0.000
E . .
~ AT T (s Right Distance 0.000
ok | Cancel |




