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Frame Analysis Using Multiframe

1. The software is on the computers in the College of Architecture in Programs under the Windows
Start menu (see https://wikis.arch.tamu.edu/display/HELPDESK/Computer+Accounts for lab
locations). Multiframe is under the Bentley Engineering menu.

2. There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks
and order in greater detail. The first task is to define the unit system:

e Choose Units... from the View menu. Unit sets are available, but specific units can
also be selected by double clicking on a unit or format and making a selection from the
menu. Pressure units are used for distributed area loads on load panels.

Units
nit Set: Canfiguration:
American Unit Type Unit Decimal Places| Format ~
gk‘?‘f;"ﬂ“ 1 |Length ft - 3 Fixed Decimal | |
il = : :
Canadian 2_ Angle _ d.eg 3 F?xed Dec?mal
European 3_ Deflection in 3 Fixed Decimal
Japanese 4_Rcdation dey 3 Fixed Decimal
S_Fcurc:e [l 3 Fixed Decimal
B_ hdarment lkaf -1t 3 Fixed Decimal
T-'_ Dist. Force lkafoft 3 Fixed Decimal
8_ Stress ksi 3 Fixed Decimal
9 |Mass b 3 Fixed Decimal
EMagsn_ength Ikt 3 Fixed Decimal
l.ﬂ.rea in? 3 Fixed Decimal
i it of Inertia in“4 3 Fixed Decimal
EDensﬂ\; Ikt 3 Fixed Decimal
i Section Modulus in® 3 Fixed Decimal 4|
] | Cancel |
3. To see the scale of the geometry, a grid option is available: erid X
e Choose Grid... from the View menu Slpaciig

x [1.000 f
y [1.000 i

Cancel |
4. To create the geometry, you must be in the Frame window (default). The symbol is the
frame in the window toolbar:
b eafiai=lfealea]
The Member toolbar shows
ways to create members: H/’ N = o2 [
The Generate toolbar has convenient tools to create typical structural
shapes. ‘m‘\ﬁﬁﬁﬁxﬁmm

e To create a frame, use the multi-bay frame button:

ERGET
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Enter the number of bays (horizontally), number of stories (vertically) and the

corresponding spacings:

Generate Frame

X
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— Primary Structure

Murnber of bays

Mumber of stories

Humber of frames

Eay spacing 20.000
Stary height 5.000
Frame spacing 0.000

149 1]

ft
ft

uhits

= Secandany Stucture

MHumber of Secondan Beams
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Secandan Beam Direstion

m

o]

Cahicel |

e [fthe frame does not have regular bays, use the add connected

members button to create segments:

JJ./'N?‘é

A

e Select a starting point and ending point with the cursor. The location of the cursor and
the segment length is displayed at the bottom of the geometry window. The ESC button
will end the segmented drawing.

e The geometry can be set precisely by selecting the joint (drag), and bringing up the joint
properties menu (right click) to set the coordinates.

e The support types can be set by selecting
the joint (drag) and using the Joint Toolbar
(fixed shown), or the Frame / Joint
Restraint ... menu (right click).

NOTE: Ifthe support appears at both ends 4
of the member, you had the member 4

selected rather than the joint. Select the
joint to change support for and right click to select the
joint restraints menu or select the correct support on the

joint toolbar.

b
i
o>

The support forces will be determined in the analysis.

Restrained displacements:

oy B2
I 2

Cancel |
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5. All members must have sections assigned (see section 6.) in order to calculate reactions and
deflections. To use a standard steel section proceed to step 6. For custom sections the
section information must be entered. To define a section:

e Choose Edit Sections / Add FN Soct “
Section. .. from the Edit —
menu Mame: | Mew Seckion Properties:
e Type a name for your new Goup:  [Customt | Property | Value | Units | |
section Cotom 1| weight 0000l
Customn2 2 | A ooon. - int2
e Choose group Frame from Custom3 EH 0oon. intd
the group names provided Frame 4] 0000 in"d
so that the section will g_ é gggg ':“f‘
. . . =l
remain with the file data R T
e Choose a shape. The Flat s ] D .00 i
Bar shape is a rectangular L8 | L aooe .
shap g 10| i 0000 i
section. 11 tuy 0.000 in |
. Shape: Flat Bar *| [ ; "
e Enter the cross section | =zl o kel —
data. Ok | Cancel |
Table values 1-9 must have values for a Flat Bar, but not all are used for every analysis. A
recommendation is to put the value of 1 for those properties you don’t know or care about.
Properties like ty, ty, etc. refer to wide flange sections.
e Answer any query. Ifthe message says there is an error, the section will not be created
until the error is corrected.
6. The standard sections library loaded is for the United States. If another section library is
needed, use the Open Sections Library... command under the file menu, choose the library
folder, and select the SectionsLibrary.slb file.
Select the members (drag to make bold) and assign sections with the Section button on the
Member toolbar:
IPaE vl A1l s
e Choose the group name and section name:
(STANDARD SHAPES) (CUSTOM)
Select Section x|
Group: Section: B SR
W ~ 445335 ~ Eﬁgle ;I
I Ml Wwiddu290 |
5 W42 ngb'e Angle
WT W22 5o Tubs
MT w4524 R Toe
5T W445230 HEE Round
C widy224 HSS Square
HF‘E wjg:égg HS5 Rectangular
Angle WADs53 Eﬂztgm;
P Aok a0y Custons
e ) [ 5l Lo |
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7. Ifthere is an area that has a uniformly distributed load, load panels may be defined in the
Frame window. Because the loaded area may not be visible in the current view, choose the
View button at the lower left of the Frame window. The options for view are shown. (See
3D Frames, last page.)

e Choose the panel type (rectangular, 4-node, or 3-node) from the 7l
menu and select the corners. If the area is rectangular, only the
opposite corners need to be selected.

e Select the panel and from the pop-up menu, or the
Frame menu, specify the load panel supports. The :
default supports are on all sides. If the panel is one 4“@""‘”&' 5 SE‘E’ E

way, chose the corresponding picture

Load Panel Support Types

8. The frame geometry is complete, and in order to define the load ]
conditions you must be in the Load window represented by the “ p! d] | |
green arrow:

9. The Load toolbar allows a joint to be loaded with a force or a moment in global coordinates,
shown by the first two buttons after the display numbers button. It allows a member to be
loaded with a distributed load, concentrated load or moment (next three buttons) in global
coordinates, as well as loading with distributed or single force or moment in the local
coordinate system (next three buttons). It allows a load panel to be loaded with a distributed

load in global or local coordinates (last two buttons).
RN LT SRR . T2

e (Choose the member to be loaded (drag) and select
the load type (here shown for global distributed Pldd 2 e rs @y
loading):

e Choose the distribution type and x|
direction. Note that the arrow
shown is the direction of the  Shape
loading. There is no need to put in w ,HT”“ i“h w1
negative values for downward o A f‘ﬂﬂ-- s ane ALt d
loading. R - N

e Enter the values of the load and ~ Direction
distances (if any). Distances can be & p” Left Magnitude 000 kipdit
entered as a function of the length , Fight Magnitude [ ke
ie. L/2, L/4... & o : _

eft Distance W ft

e Area load units may have to be L T

changed in the Vie\}:v Units dialogue. e Disanee —— '
ok, I Cancel |

NOTE: Do not put support reactions as

applied loads. The analysis will
determine the reaction values.
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Multiframe will automatically generate a grouping called a

Load Case named Load Case 1 when a load is created. All
additional loads will be added to this load case unless a
new load case is defined (Add case under the Case menu).

In order to run the analysis after the geometry, member

properties and loading has been defined:

Choose Linear from the Analyze menu

S2013abn

Sections
mal

Load Case 1

Ready

Zi\arche

If the analysis is successful, you can view the results in the
Plot window represented by the red moment diagram:

The Plot toolbar allows the numerical values to be shown (1.0
button), the reaction arrows to be shown (brown up arrow) and
reaction moments to be shown (brown curved arrow):

To show the moment diagram, Choose the red Moment button

——

=kl s

To show the shear diagram, Choose the green Shear button

To show the axial force diagram, Choose the purple Axial

Force button

To show the deflection diagram, Choose the blue Deflection

button

[ s

=% & < [T o
el & = [ o

[l %

=

|

To animate the deflection diagram, Choose Animate... from

the Display menu. You can also save the
animation to a .avi file by checking the
box.

To plot the bending moment on the “top”
choose Preferences from the Edit menu
and under the Presentation tab Draw
moments on the compression face

To see exact values of shear, moment and
deflection, double click on the member
and move the vertical cross hair with the
mouse. The ESC key will return you to
the window.

My M P
L_" h"-\-l

i

iz
Wyt
dy'

Wiy
Dist

19485134 Ibf-t
0.000 bt
-0.078in
-500.000 kf it
12,5001

E

Dist

3 I e Mz’
Mz Wy
e oy
Ifi: Wiyt

19577 370 Ibf-ft
62:30.000 bf
0.073in
S00.000 [kt it
12.500 1

Ready

Static Caze: Load Case 1 Member 3 (4 Primary Beam) all

Z:harche
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13. The Data window (D) allows you to view all data “entered”
for the geometry, sections and loading. These values can be

edited.

14. The Results window (R) allows you to view all results of the
analysis including displacements, reactions, member forces (actions)
and stresses. These values can be cut and pasted into other Windows programs such as Word

or Excel.

NOTE: Px’ refers to the axial load (P)
in the local axis x direction (x’). Vy’
refers to the shear perpendicular to
the local x axis, and Mz’ refers to the

bending moment.

S2013abn

il

| &/ M| E] E]

miaialcicliala

Static Case: Load Case 1

. Px’ vy Mz’

Memb| Label | Joint ‘ T | Ibf ‘ T |
1 1 Calumn 1 6250.000 ; -17586.5320 -9725.754
2 1 Column: 3 -6250.000 ¢ 1786320 -19577.371
3 2 Column 2 E250.000° 1786320 9725754
4 2 Column 4 -6250.000 1786320 19577.371
5 3 MPrima 3 1786.320 0 6250.000 19577371
B 3 MPrima 4 1786320 E250.000 -19577.371 |

-

MMemher Actions A Max Acti] 4 e
Ready Zi\arche

15. To save the file Choose Save from the File menu.

16. To load an existing file Choose Open... from the File menu.

17. To print a plot Choose Print Window... from the File menu. As an alternative, you may copy
the plot (Ctrl+c) and paste it in a word processing document (Ctrl+v).

Example of Combined Stresses:

for member 3: My.x = 19.6 k-ft, P= 1.76 k
knowing A = 21.46 in’, I = 796.0 in*, ¢ = 7.08 in

176k 19.6""-7.08in 12in

e

= 0.082ksi+2.092ksi = 2.174ksi

= ) . 4
21.46in 796in ft
Results window:

Static Case: Load Case 1 -

Memb| Labet | Joint Shz t_op Shz I_Jot W Sn_ Sx +Shz_ top | Sx +Shz_ hot

ksi ksi ksi ksi ksi ksi

1 1 Column: 1 1.039 -1.039 ¢ 1152461 0.286 1.325 0753

2 1 Colurmn 3 -2.092 2092 1152461 0.286 -1.806 2378

3 2 Column: 2 -1.039 1039 1152461 0.286 -0.753 1.325

4 2 Column: 4 2.092 -2.092° 1152461 0.286 2378 -1.806

5 3 MPrima: 3 -2.092 2092 4032245 0.0s2 =201 2174

G 3 MPrima: 4 -2.092 2092 -4032.245 0.0&2 -2.01 2174
-

Ready

|4 [+ [A\Member Stresses A Max Stresses £ Mernber [] 4

[

Z:\arche31\Fosh assignsimultiframelSa. mfd*  |MUM

where Sx’ refers to the axial stress, Sy’ refers to the bending stress around the local vertical
axis and Sz’ refers to the bending stress around the local horizontal axis.

6



ARCH 331 Note Set 12.3 S2013abn

For 3D Frames:

e There are tutorials available on line at http://www.formsys.com/mflearning that list the tasks
and order in greater detail. It expects that you have been through the 2D tutorial to build on

the steps already mastered.
e There are standard 3D frame shapes on the frame toolbar. ‘ oy O Mo A h

e It is very useful to change the view to isometric with the View Button

“® Frame [Z]@
— 1 H S Hm e | M

- - = -
Y T S Y -
.

Sections E
-

/ View
P

=
Left Front

e

Viewlm T % T 5 I

Bottom

o If you wish to have additional beams supported by the beams of your frame, choose the beam
and use the Subdivide Member menu under Geometry. This will make additional joints, but

keep the segments together.

F ~
Subdivide Member =5
Mo. of subdivisions ]
Member| Proportion Length 7
1 1 0.500 10.000 "
2 2 0.500 10.000
3| Total 1.000 20.000 oK
-
L]
¥ 2
Connect to existing Group as Design Member u

4

e In order to model a beam end as simply supported, you must release the restraint preventing
rotation about the x-x axis of the beam. The pinned ends menu is useful for segments or

subdivided members. :

VT ERIP2 A
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Or, by selecting a segment and right clicking for a
menu, you can use Member Releases (also under the
Frame menu) to release the Major Bending (M'z) for

one end or both.

S2013abn

r |
Member Releases &J

Member Releases

//;f’

Joint 1 Joint 2:
Oty Torsion Orv
[my' Minor Bending [ my
Mz Major Bending [ iz
ey Axial [Ty

0K

Cancel

o It is necessary to understand the local member axes to assign the correct load direction.

Choosing the /ocal loading types will show the member orientation with respect to the load

direction.

W Load

=%

Py ol

/EWUD

1000100
1000 - 4
1000

1000 &
1000

non

Load Casze 1

-

Local Distributed Load

View | - | E:

Shape

W

[}

Direction

We

L

A
L

e

Left Magnitude 1.0000 IBf/E
f'“
e Right Magnitude 1.000 Ibfift
2 Left Distanice 0.ann
(s Right Distance 0.000
ok | Cancel |




